Announcement

Collapse
No announcement yet.

Sandbox Editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Great editor glad to see its been pushed into the main servers
    Good work
    It's a good day for some scripts

    Comment


      #17
      Amazing work, bud.
      Game Developer @ Onset RP // Early Access tester // Wiki Contributor

      Comment


        #18
        Schematics has been added. Save and load custom builds for future use.
        • /schematic save <name> - Save the current selection you have.
        • /schematic load <name> - Load the saved schematic and put it on your clipboard.
        • /schematic list - List all available schematics.
        Enjoy.

        Comment


          #19
          I followed the installation instructions but seem to be having an issue. If I use the chat commands, I get a response which indicates that the package should be working. However when I try to use any of the keys to toggle editor or open scoreboard, none of them are working. Is there something that I missed?

          EDIT: Well, that was annoying. After coming back to it, I just decided to setup a server in a different directory and now it works just find. Super weird.
          Last edited by Duetschbag; 12-23-2019, 01:58 AM.

          Comment


            #20
            Package "onset-sandbox-editor-master" contains invalid characters or has an invalid length

            Comment


              #21
              Okay, I'm back again! Haha!

              I ran another test today while setting up a server. I downloaded a fresh server using SteamCmd, and only have sandbox, default and packagemanager in my server_config.json. The only other change to the server config was setting the IP to 0.0.0.0 since I'm connecting from a remote PC. On my Windows Server 2012 R2 machine, the package appears to load properly (in the console) once the server starts. However, when I log into the server from my Windows 10 machine, I connect successfully, but the editor is not available.

              Then, if I copy the server directory over to my local Windows 10 machine (no changes made) and launch it, I can connect to the server successfully and the editor works just fine.

              So something weird is going on, but I'm kind of at a loss.

              Comment


                #22
                Hei, I wonder why some object when placed in the world they dissapear, but they do get on the world.json. When I place them they dissapear after 1 second.

                Comment


                  #23
                  Hi, great tool, when is the next update?
                  And its content if possible ?

                  Comment


                    #24
                    Originally posted by Fasterz View Post
                    Hi, great tool, when is the next update?
                    And its content if possible ?
                    Any suggestions?

                    Comment

                    Working...
                    X